Search found 14 matches

Return to advanced search

Thanks! That does help. I think that may be just what I needed; I'll look into it.
by Juz10mac
Sep Sat 29, 2007 2:42 pm
 
Forum: Creation Room
Topic: A question on computer systems design
Replies: 2
Views: 6513

A question on computer systems design

Okay, I apologize. This isn't exactly Replica I, but I think this will still be the best place to get an answer to my question. The Replica I has sparked my interest in computer systems and their design. I've been trying to learn a little more about computer systems, and I want to try my hand at des...
by Juz10mac
Sep Mon 24, 2007 9:42 pm
 
Forum: Creation Room
Topic: A question on computer systems design
Replies: 2
Views: 6513

Changing memory addresses used by Krusader.

After reading in the Krusader manual, I found that you can change the default memory addresses it uses. To quote the Kursader manual: Figure1: Memory map for both the high RAM and the ROM versions of KRUSADER. Note that the global symbol table starts at the local/global table boundary and grows down...
by Juz10mac
Sep Sat 15, 2007 12:06 am
 
Forum: Software
Topic: Where does BASIC put its varables and code? & Memory Map
Replies: 10
Views: 17412

That works!
The syntax was the problem. I wasn't using =, I just placed the number after the command. It was just one of those careless errors that tends to happen. :D
by Juz10mac
Sep Fri 14, 2007 3:19 pm
 
Forum: Software
Topic: Where does BASIC put its varables and code? & Memory Map
Replies: 10
Views: 17412

Here are the opcodes

If you want to pretend like you are Steve Wozniak and assemble your programs by hand, here is a must-have resource:

http://www.6502.org/tutorials/6502opcodes.html
by Juz10mac
Sep Fri 14, 2007 2:02 pm
 
Forum: Software
Topic: Assembler Tool
Replies: 1
Views: 4010

daustin777 wrote:The default Basic user area is $0800 - $1000, until it's changed with HIMEM, LOMEM


Thanks!

Also, do the HIMEM and LOMEM commands work with Apple I BASIC? I only get a syntax error when I try them.
by Juz10mac
Sep Fri 14, 2007 1:25 pm
 
Forum: Software
Topic: Where does BASIC put its varables and code? & Memory Map
Replies: 10
Views: 17412

Where does BASIC put its varables and code? & Memory Map

Hello, I'm trying to understand the memory map of the Replica I a little better. I've managed to figure out where most everything is but I can't figure out where BASIC puts its variables and code. Also, I've done a little research and I should be able to change HIMEM and LOMEM, right? (I haven't bee...
by Juz10mac
Sep Fri 14, 2007 11:02 am
 
Forum: Software
Topic: Where does BASIC put its varables and code? & Memory Map
Replies: 10
Views: 17412

I'm sorry I didn't get back to you sooner. I've been devoting every free moment to learning 6502 assembly ;). The bad spot was where a printed circuit path is continued on the other side of the board (one of the tiny metal holes). This particular one is under the 74LS138 to the left side and is the ...
by Juz10mac
Jan Tue 30, 2007 1:16 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

She Works!!!

I finally got it working! This has probably been the most rewarding troubleshooting experience I have ever had, not to mention the most frustrating. After rechecking everything I could think of again and again and redoing about half the solder points, I found the problem. There was a bad connection ...
by Juz10mac
Jan Sat 27, 2007 6:08 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

Still no luck. I replaced the SRAM as a troubleshooting step to see if I had a bad IC. It behaves the same whether or not the SRAM chip is installed. the cursor does not drop down to the next line and the Replica I will not accept input from the keyboard. I have noticed that on occasion, after I pre...
by Juz10mac
Jan Sun 21, 2007 7:00 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

I checked all of the solder connections. Externally, they look good to me; all IC pins are in the sockets and all sockets are soldered to the board at each pin. I'm assuming the _ (underscore) is the cursor in HyperTerminal (it blinks). Here is what I see in HyperTerminal: \_ Here is what I see usin...
by Juz10mac
Jan Thu 11, 2007 1:05 am
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

I followed all the steps in HyperTerminal as described in the Replica1.pdf manual. When I press reset I get a backslash and a blinking underscore. I turned caps lock on and tried to type, but it still won't type. So, for some reason the Replica 1 is not getting the ASCII keyboard instructions no mat...
by Juz10mac
Jan Wed 10, 2007 11:55 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

That's interesting. I tried turning on the caps lock but it won't turn on. I still have no response from the keyboard and the caps lock LED won't turn on when I press the caps lock key. I tried holding down shift, but still no luck.
by Juz10mac
Jan Wed 10, 2007 9:15 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

Help! I need some keyboard troubleshooting.

Hello, I'm new here. I finished building my Replica 1, but am having problems getting the keyboard to work. I have tried four different PS/2 keyboards. When I apply power the keyboard LED indicators light up then go back off, just like when a PC is booted. Each time the machine comes up with the @ s...
by Juz10mac
Jan Wed 10, 2007 7:38 pm
 
Forum: Troubleshooting
Topic: Help! I need some keyboard troubleshooting.
Replies: 24
Views: 41702

Return to advanced search

cron