Search found 11 matches

Return to advanced search

I did spend some time with this recently. I tried ckermit and minicom. I was able to get kermit to perform a basic serial connection so that interactive typing worked fine. But I couldn't get it configured to do the equivalent of Hyperterminal's "character delay", so sending a text file or pasting a...
by bababooey182
Oct Thu 27, 2005 9:45 pm
 
Forum: replica 1 General Discussion
Topic: serial I/O with Linux?
Replies: 4
Views: 13073

serial I/O with Linux?

At some point I need to figure out how to use the serial I/O interface when connected to a Linux PC. I'm assuming kermit is the best software to use. Has anyone already figured out all the settings/parameters (e.g. the character delay and line delay) for kermit? If no one has details, I'll post what...
by bababooey182
Sep Thu 08, 2005 12:29 am
 
Forum: replica 1 General Discussion
Topic: serial I/O with Linux?
Replies: 4
Views: 13073

Yes, it was dropping chars. I was using a 10-ft serial cable, just because that's what I had. I need to get a DB9-DB9 cable -- do you think 6-ft is OK?
by bababooey182
Sep Wed 07, 2005 8:59 am
 
Forum: Troubleshooting
Topic: serial I/O character delay
Replies: 2
Views: 7848

reset with the serial I/O board?

A question out of curiousity... With the serial I/O card connected, when I hit the RESET button on the Replica 1 board, I don't get the backslash-newline from the woz monitor through the serial console. It does reset and put me in the woz monitor, but it doesn't print the \ Is that the expected beha...
by bababooey182
Sep Wed 07, 2005 12:12 am
 
Forum: Troubleshooting
Topic: reset with the serial I/O board?
Replies: 1
Views: 6169

blackjack starting address?

What is the starting address of the program at http://www.brielcomputers.com/blackjack.txt?
by bababooey182
Sep Wed 07, 2005 12:07 am
 
Forum: Software
Topic: blackjack starting address?
Replies: 1
Views: 5293

hamurabi fixes

In playing around with the hamurabi basic program at http://www.brielcomputers.com/HAMURABI.txt I uncovered two issues: 1) as-is it generates a MEM FULL error, and 2) it has a syntax error on line 252. To fix problem (1) add these lines to the top of the file: SCR LOMEM=768 To fix (2) change line 25...
by bababooey182
Sep Tue 06, 2005 11:48 pm
 
Forum: Software
Topic: hamurabi fixes
Replies: 1
Views: 4855

serial I/O character delay

I got my serial I/O board today, and I've been fooling around with the programs from the website. The Replica 1 manual says to configure HyperTerminal this way: 1) Line delay = 500 ms, 2) Character delay = 10 ms. After some experimenting I found that anything less than 20 ms character delay results ...
by bababooey182
Sep Tue 06, 2005 11:36 pm
 
Forum: Troubleshooting
Topic: serial I/O character delay
Replies: 2
Views: 7848

A few additional toy programs for people who are fiddling with a Replica 1 without a serial I/O board. ; written for Van Ornum's 6502 assembler start *= $300 msg: .byte "HELLO WORLD ",0 top: LDX #0 loop: LDA msg,X BEQ top JSR $FFEF INX JMP loop 300: 48 45 4C 4C 4F 20 57 4F : 52 4C 44 20 00...
by bababooey182
Aug Sun 28, 2005 12:04 am
 
Forum: Software
Topic: Test Program from the Apple 1 Manual
Replies: 1
Views: 5952

Test Program from the Apple 1 Manual

I'd suggest adding the 11-byte test program from the original Apple 1 manual ( http://www.brielcomputers.com/a1man.pdf ) to the downloads section of the site. I haven't got a serial I/O board yet, so I needed a very small hello-world program to try on the Replica 1. Of course I fired up BASIC to mak...
by bababooey182
Aug Thu 25, 2005 1:34 am
 
Forum: Software
Topic: Test Program from the Apple 1 Manual
Replies: 1
Views: 5952

I figured that was the case, but wanted to confirm. I totally agree with your philosophy of replicating exactly. Perhaps a brief note in the Replica 1 manual about how the Apple 1 does backspacing would be worthwhile.

Thnk__anks! :D
by bababooey182
Aug Mon 15, 2005 10:55 am
 
Forum: Troubleshooting
Topic: backspace with ps/2 keyboard?
Replies: 7
Views: 18332

backspace with ps/2 keyboard?

I got my replica 1 powered up for the first time today. I'm using a ps/2 keyboard. I can logically backspace using the underscore character, but the display doesn't actually backspace. It just prints the underscore character. For example "1234_5" is really "1235". Is this the expected behavior when ...
by bababooey182
Aug Sun 14, 2005 11:33 pm
 
Forum: Troubleshooting
Topic: backspace with ps/2 keyboard?
Replies: 7
Views: 18332

Return to advanced search

cron