Page 1 of 1

No display, power LED lit

PostPosted: Mar Sat 28, 2009 3:59 pm
by rdk
Hi Vince,

I just finished my Micro-Kim over a period of four very enjoyable days. Thanks for bringing the Kim back to life with your replica - it's a real blast from the past! Thanks, too, for the super fast shipment of the three missing caps. Much appreciated.

I'm at a dead end right now. I just powered up the Kim for the first time, and the only indication I have is an illuminated power LED. All six of the 7-segment displays are dark. Here's what I've checked so far:

- No unsoldered pads.
- No cold solder joints.
- No solder bridges (caveat on the last three...none that I see after a careful inspection, anyway).
- All ICs installed with the correct orientation, and all have been reseated.
- JP1 is on, and JP2 off.

I'm powering the Kim with a 7.5V 1000ma power supply.

- Voltage at the regulator input is 7.5V, and 5.0V at the regulator output.
- 5.0V Vcc is present on all chips on the appropriate pins.
- Pressing RS upon power-up has no effect.

I'd check the 1 MHz output of the oscillator to ensure that it is running, but I have no access to either a freq counter or an oscilloscope. My only piece of test equipment is a DVM.

What's my next step at this point?



PostPosted: Mar Sat 28, 2009 5:04 pm
by vbriel
Well, the best you can do with the oscillator is check it by voltage. Since it should be putting out a square wave it will measure about 2.3V on the output pin.

You can check some pins on the 6502 to tell if it is running:

SYNC pin 7 on the 6502 goes high during phase 1 and stays high for the remainder of that cycle. It goes high to indicate an instruction fetch request from memory. Measure this pin with it running after pressing reset.

READY pin 2 is an input that should be kept at 5V. It is only pulled low to DMA to memory or devices. Measure this pin. It should be 5V or very close.

Phase1 out pin 3. This is a clock output signal. If the clock is working on the CPU, it will have an ouput of around 2.3-2.6V. If it is 0, there is a problem.

Phase2 output pin 39. This is for the most part the same as phase1 just timed 180 degrees off. Should measure the same voltage as phase 1.

Phase0 input pin 37. This is the clock signal generated by the oscillator. Should measure 1Mhz or around 2.3V

Check these, and check things like the address lines to see if pressing reset changes the address it is at.

The power supply sounds like perfect specs, so, maybe there is a bad chip.


PostPosted: Mar Sat 28, 2009 9:41 pm
by rdk
Here's the results of my measurements:

SYNC pin 7 - 1.25V after pressing reset.

READY pin 2 - 5.0V.

Phase1 out pin 3 - 2.29V.

Phase2 output pin 39 - 2.29V.

Phase0 input pin 37 - 2.5V


PostPosted: Apr Mon 13, 2009 10:32 pm
by rdk
After posting this last set of measurements Vince suggested that I send my Kim in for troubleshooting, which I did. The problem turned out to be a faulty 6532. Vince replaced the chip, tested the Kim, and shipped it back to me via Priority Mail. I just finished keying in the clock program and it runs like a champ. Total time from the afternoon when I dropped the Kim off at the post office until it was back in my hands: six days. It just doesn't get any better than that!

Or does it? I forgot to mention that Vince didn't charge one cent for his time or the shipping costs back to me. Needless to say, I'm absolutely delighted.

Vince, thanks for everything. You can bet that I'll be building more of your kits. Next on the list will be a PockeTerm.

A very happy customer,


PostPosted: Jun Tue 02, 2009 8:07 am
by nashtr
Hi Vince,

I'm having the exact same issue with mine, power LED is on, no display. I also tried a serial connection and got no response, but I'm not entirely sure I did that right (using a Mac and ZTerm). I'm using the power supply from Mouser referenced in another discussion here ( ... wer+supply ), so I don't think that's the issue.

I do have one silly question, I check the pin voltages relative to the ground pin on the chip itself, correct? Or relative to another gound point on the board? I'm going to meet with the prof whose class I'm making it for in the next few days, I'll have him double check my soldering, and try swapping chips with his working MK one at a time to see if that works.

I wonder if I can convince him to give me extra credit for finding the issue? :D

PostPosted: Jun Wed 03, 2009 2:14 pm
by vbriel
When checking voltages, check them in refrence to ground. There are holes for mounting on the board corners. The rings are a ground source.

Having your prof's MK will really help troubleshoot the problem down.


PostPosted: Jun Thu 04, 2009 2:57 pm
by nashtr
Well, my face was red enough to stop traffic last night. :D Took it into the professor last night, he turned it over and looked at it for a minute and started laughing. Turns out that during one of my late night soldering sessions, I didn't solder all of the pins on the CPU's IC socket. A few minutes in the soldering lab, a few keystrokes, and it was running the clock. So the problem was PEBSIAC. Problem Exists Between Soldering Iron And Chair. :oops:

PostPosted: Jun Thu 04, 2009 8:42 pm
by vbriel
It's always the first thing I have people check. So, does this mean it is working?


PostPosted: Jun Fri 05, 2009 7:59 am
by nashtr
I still haven't checked the serial connection, but yes, it's working fine now. My stupid mistakes aside, it was a fun build, I just waited too long to start on it, and tried to do too much at one sitting. The prof even complemented me on the soldering connections that I remembered to do. :D Even though I'm technically done with the project now, I'm looking forward to playing with my new toy this weekend. I can now wear my t-shirt I bought with pride:

Next up, sometime this Summer or Fall, the Replica 1.

Re: No display, power LED lit

PostPosted: Aug Sun 28, 2011 12:10 pm
by mathubbard
Built mine last week.

All the parts were present apart from a missing resistor which was easily sourced. On power-up the LED worked but nothing else. All the power supply voltages seemed correct so I lifted a Synertek 6502 out of an old Acorn BBC micro, and it burst into life - I assume the 6502 supplied was dodgy.

Now everything appears to work apart from the RS-232 interface. With the jumper fitted, the keypad and display still operate and the RS232 interface doesn't. Any ideas? What do 'I need to look for?


btw: the build kept me entertained for a few hours - worth it just for that!