No keyboard input

Talk about the PockeTerm, updates, and uses

No keyboard input

Postby jscheef » Aug Thu 30, 2012 4:39 pm

I finally found a suitable wall wart for power and got around to trying out my preassembled PockeTerm. The display comes up within a second of applying power but I cannot get any response on the keyboard. The keyboard is known good. I'm sure it tested good when it was assembled, so what should I do to diagnose this problem?

Thanks,
Jim
jscheef
 
Posts: 4
Joined: May Fri 25, 2012 12:56 pm

Re: No keyboard input

Postby williad » Aug Fri 31, 2012 7:30 am

Hi Jim,

It is possible you need to add the two 10k pull up resistors. I don't think Vince has updated the board yet to include them. See this topic for details viewtopic.php?f=21&t=463

Regards
David
williad
 
Posts: 8
Joined: Apr Wed 14, 2010 9:02 am

Re: No keyboard input

Postby jscheef » Aug Fri 31, 2012 8:56 am

David,

Reading that thread, my situation seems different. The keyboard initializes (status lites cycle once or twice) so there is power - just no response when you press a key. With nothing connected to the term port, only the F-keys should respond regardless of any other settings and there is no response to anything.

My electronic diagnosis tools are limited to a VOM. Anything I can check?

Jim
jscheef
 
Posts: 4
Joined: May Fri 25, 2012 12:56 pm

Re: No keyboard input

Postby williad » Sep Wed 05, 2012 8:51 am

Hi Jim,

The two 10kOhm resistors are used to pull the clock line & the data line up to +5 Volts - as the data signal & the Clock signal are open collector (ie just either switch to ground or are open circuit). The keyboard will reset when power is applied as the +5V power supply is connected on the power pins.
Either you could fit the pull up resistors & see if that fixes your problem or you could use your VOM to check the voltage on the Clock pin & the Data pin relative to the ground pin with the keyboard connected to the Pocketerm. If with the VOM you see no voltage then you definately need the 10kOhm resistors fitted.
I fitted the two 10kOhm to the track side of my pocketerm & haven't had a keyboard yet which didn't work. 1/4 watt 5% could be used but I used 0.6W 1% metal film resistors as I had them on hand.

Regards
David
williad
 
Posts: 8
Joined: Apr Wed 14, 2010 9:02 am


Return to PockeTerm General Discussion

Who is online

Users browsing this forum: No registered users and 1 guest