Single-Step Issue with 65C02

Discuss problems with your Micro-KIM here

Single-Step Issue with 65C02

Postby timali » Mar Wed 08, 2017 8:47 pm

My Micro-KIM shipped with a 65C02, and apparently there is a timing issue which prevents single-step from working with the 65C02. I tried an original NMOS 6502, and single-step worked ok with it, but not with any of my 65C02s. I did some debugging with my scope and determined that there is a small timing difference causing the SST signal to be erroneously asserted (pulled low) for 100-200 ns during EEPROM accesses with the 65C02, which is just enough to cause a problem. The easiest way I could think of to fix this was to delay the SYNC signal briefly with a small RC circuit, which prevents the glitch in the SST signal. I cut a trace on the back side of the board and added a small resistor and capacitor, and VIOLA, single-step is now working correctly with my 65C02's. It still works with the original 6502, also.

I attached the workaround in case anyone else is interested. I was writing some software on the Micro-KIM at the time, and having single-step really helped out. Also, if anyone else has a better method of fixing single-step for 65C02's, I'd love to hear it.
Workaround for Single-STep on 65C02
Single-Step_Fix.JPG (31.79 KiB) Viewed 20061 times
Posts: 6
Joined: Mar Thu 22, 2012 6:30 am
Location: Raleigh, NC, USA

Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest