Can't set vector locations

Discuss problems with your Micro-KIM here

Can't set vector locations

Postby minimicrite » Oct Mon 10, 2011 10:37 pm

Finally got around to powering up my Micro-KIM from the 'I can't solder' sale, and I'm a bit stuck. It powers on fine, and I can enter an address and modify the contents of that address. That is, everywhere except 17FA-17FF. I can't set the vector locations. I hit 'AD', type '17FB', hit 'DA', and type '1C', but the two value LED's never change from 00. Same for '17FF', value stays at '00', no response to keyboard input after 'DA'.

I tried entering the fist simple program from The First Book of Kim (below), but all that happens is the display goes blank when I return to 0200 and hit 'GO', which I assume is because I can't set vector locations.
0200 A5 10 START LDA 10 address 10 to A
0202 A6 11 LDX 11 address 11 to x
0204 85 11 STA 11 A to address 11
0206 86 10 STX 10 X to address 10
0208 00

Any ideas?
minimicrite
 
Posts: 9
Joined: May Thu 24, 2007 7:25 pm
Location: Nicholasville, KY / Katy, TX

Re: Can't set vector locations

Postby jipock » Dec Thu 22, 2011 10:48 am

I'm seeing the same issue, did you find a resolution?
jipock
 
Posts: 19
Joined: Dec Mon 27, 2010 3:16 pm

Re: Can't set vector locations

Postby vbriel » Dec Thu 22, 2011 9:02 pm

My first thought would be bad RAM in the 6532. If you are able to read/write in other locations I'm pretty sure the RAM is bad at those locations.

It could be a solder connection, check these connections with a meter to make sure the connection is there:

The lower 74LS00 is U19. Check that pin 4 on that goes to the 74LS138 pin 9. On U19 pin 5 goes to 74LS138 pin 7 (yes 2 connections to pin 7).

On U19 pin 6, 9 and 10 are all connected. Check you get connection there.
On U19 pin 8 goes to pin 13 on the other 74LS00 (upper chip) called U14 and pin 8 also goes to pin 36 on the 6532.
On U14 (upper chip) pin 12 goes to pin 10 on the 74LS138 and pin 11 on U14 goes to pin 38 on the 6532.

Just for reference, the RAM in the 6532 is in sections 1780-17BF and 17C0-17FF. Let me know if you can write to any of these 2 sections.

Vince
User avatar
vbriel
Site Admin
 
Posts: 1184
Joined: Jul Tue 19, 2005 12:10 pm
Location: Ohio

Re: Can't set vector locations

Postby minimicrite » Jul Sat 28, 2012 11:25 pm

Vince:

Sincere apologies on the delay. I've not had much time for my old hobbies lately.

Anyway, I've checked all the connections that you list, and all are okay. I paged through a few of the memory locations starting from 1780, and compiled a list of what I observed. Note, though that at a few locations, the two memory contents LEDs would flicker for a bit before returning to 00 or 01.

1780-178F can only write one character (0x)
1790-1798 only 00 or 01 (pressing 0, 2, 4, etc, results in 0; pressing 1, 3, 5, etc results in 1)
1799 sometimes can write 01, other times 01 reverts to 00 as soon as '1' key is released
179A-179C nothing can be written
179D-179E only 01 or 00
179F-17A0 can only write 00-0F
17A1 can only write 00, 02, 04, 06, 08, 0A, 0E

Can set 17FF to 1C per instructions on setting vector locations on page 16 of the micro-KIM manual. 

Does this help narrow down what's going on?

(In pulling out the micro-KIM, I also discovered that I bought an A2MP3 card. Maybe I'll get the kids to bed an hour early tomorrow night so I will actually have time to build it!)
minimicrite
 
Posts: 9
Joined: May Thu 24, 2007 7:25 pm
Location: Nicholasville, KY / Katy, TX


Return to Troubleshooting

Who is online

Users browsing this forum: No registered users and 1 guest

cron